Ticket #1605 (closed 改善提案: 修正済)

Opened 9 years ago

Last modified 8 years ago

PHP4向けコードの除去、PHP5向けのコード最適化(for 2.12.0)

Reported by: AMUAMU Owned by: somebody
Priority: Milestone: EC-CUBE2.12.0
Component: その他 Version: 2.12.0 α
Keywords: Cc:
修正済み: yes

Description

PHP4対応が無くなる事による不要コード除去、コード最適化。

・専用で実装しているコードや、余計な処理部分を除去する。 ・最低動作環境がPHP5.1.6以上対応となることで最適化が出来る処理を見直す。

※クラス内のプロパティやメソッドのアクセス権(visibility)キーワード定義の利用、抽象クラスの利用、オーバーロード利用、タイプヒンティング利用については別途議論が必要かと思います。

Change History

comment:1 Changed 8 years ago by h_yoshimoto

  • Milestone changed from EC-CUBE2.12.2 to EC-CUBE 2.12.3

comment:2 Changed 8 years ago by kim

  • Status changed from new to closed
  • 修正済み set
  • Summary changed from PHP4向けコードの除去、PHP5向けのコード最適化 to PHP4向けコードの除去、PHP5向けのコード最適化(for 2.12.0)
  • Resolution set to 修正済
  • Milestone changed from EC-CUBE2.12.3 to EC-CUBE2.12.0

AMUAMU様、Seasoft様 いつもありがとうございます。 本チケットは2.12.0用の対応として、 r21663 r21660 r21650 r21583 r21465 のコミットをもってクローズとさせていただきます。

Note: See TracTickets for help on using tickets.