Ticket #205 (closed バグ指摘: 修正済)

Opened 14 years ago

Last modified 14 years ago

WEBサーバでAlias使用時にLC_Page::getLocation()が正常に動作しない

Reported by: adachi Owned by: somebody
Priority: Milestone: EC-CUBE
Component: フロント Version: 2.0系(正式版)
Keywords: Cc:
修正済み:

Description (last modified by adachi) (diff)

 http://xoops.ec-cube.net/modules/newbb/viewtopic.php?topic_id=1481&forum=9

apache(他のWEBサーバでも同じ動作だと思います。)にてaliasの設定をすると、
設定次第では(ほとんどの場合でしょうが)リダイレクトが上手く行かなくなるようです。

例えば

アプリケーションの配置が
/home/user/eccube2/
/home/user/eccube2/html/
/home/user/eccube2/data/
上記のような場合。

(長くなるのでAlias部分のみ記述します)
Alias /hogehoge/ "/home/user/eccube2/html/"
(http://hostname/hogehoge/)でアクセスするように
上記のようにAlias設定をすると、
管理側ログイン認証後管理側トップページにリダイレクトしません。
(認証自体は成功してるので直に/admin/home.phpにアクセスすると遷移する。)

尚、/install/index.phpにて設定をする際、
下記の項目は最初から表示されている情報で登録しております。

■WEBサーバの設定
HTMLパス※ /home/user/eccube2/html/
URL(通常)※ http://hostname/hogehoge/
URL(セキュア)※ http://hostname/hogehoge/

シンボリックリンクでも同様のようです。  http://xoops.ec-cube.net/modules/newbb/viewtopic.php?topic_id=1601&forum=9&post_id=5778#forumpost5778

Change History

comment:1 Changed 14 years ago by adachi

  • Version changed from 2.0系(ベータ版) to 2.0系(正式版)

comment:2 Changed 14 years ago by adachi

  • Description modified (diff)

comment:3 Changed 14 years ago by satou

  • Status changed from new to closed
  • Resolution set to 修正済

r17042 修正しました。

comment:4 Changed 14 years ago by adachi

  • Milestone changed from EC-CUBE2.0 to EC-CUBE

マイルストーン EC-CUBE2.0 自体が削除された。

Note: See TracTickets for help on using tickets.