Ticket #449 (closed 改善提案: 修正済)

Opened 12 years ago

Last modified 10 years ago

旧バージョンの PHP で動作しない

Reported by: Seasoft Owned by: kajiwara
Priority: Milestone: EC-CUBE2.4.4
Component: その他 Version: 2.3.4
Keywords: Cc:
修正済み:

Description

 http://xoops.ec-cube.net/modules/newbb/viewtopic.php?topic_id=3854&forum=2

察するに、恒常的にテストができないようですし、そろそろ PHP 4.3.3 以降などの対応にした方が良い気がします。

そうでないなら、参照スレッドに書いたような、互換関数を徹底して提供するのか。

Change History

comment:1 Changed 12 years ago by kajiwara

  • Milestone changed from EC-CUBE2.4.0 to EC-CUBE2.x.x

本件、ご報告ありがとうございます。>Seasoft様

ご指摘の通り、オフィシャルサイトにございますEC-CUBEのシステム要件に誤りがございました。
 http://www.ec-cube.net/product/system.php

こちらのシステム要件ですが、以前までダウンロードが可能でした、EC-CUBE1系 を含めた形でのシステム要件となっております。

対応としましては、まずは2系のみのシステム要件を検討させていただき、作成する必要があると思いますので、2.4.0のリリースなどには関わらず、対応させていただきたいと思います。

本件、一旦、マイルストーンを2.X.Xにさせていただきたいと思います。

申し訳ございませんが、以上よろしくお願いいたします。

comment:2 Changed 11 years ago by nanasess

  • Milestone changed from EC-CUBE2.x.x to EC-CUBE2.4.4

こちらも参照

 http://xoops.ec-cube.net/modules/newbb/viewtopic.php?topic_id=926&forum=2&post_id=2861#forumpost2861

PHP4.2.x だと, 動作しないことが明白です. 未だにシステム要件が PHP4.1.x 以降となっているので, PHP4.3.3 以降とするべき.

システム要件を変更するのみの対応で良いと思いますので, milestone:EC-CUBE2.4.4 としておきます

comment:3 Changed 10 years ago by nanasess

  • Owner changed from somebody to kajiwara

comment:4 Changed 10 years ago by kajiwara

  • Status changed from new to assigned

comment:5 Changed 10 years ago by kajiwara

  • Status changed from assigned to closed
  • Resolution set to 修正済

オフィシャルサイトのシステム要件を修正いたしました。

 http://www.ec-cube.net/product/system.php

こちらにて、本チケットは一旦終了としたいと思います。

comment:6 Changed 10 years ago by Seasoft

コミュニティ・関連 r18191

Note: See TracTickets for help on using tickets.