Ticket #2593 (new 改善提案)

Opened 6 years ago

Last modified 6 years ago

PHP5.5.xでMySQL 拡張モジュール が非推奨になったのでMySQLi か PDO_MySQL に変更する

Reported by: kimoto Owned by: somebody
Priority: Milestone:
Component: その他 Version: 2.13.2
Keywords: Cc:
修正済み: no

Description

 http://php.net/manual/ja/migration55.deprecated.php

PHP 5.5.x で推奨されなくなる機能 ¶

ext/mysql 拡張モジュール ¶

MySQL 拡張モジュール が非推奨になりました。これを使ってデータベースに接続すると、 E_DEPRECATED エラーが発生します。 かわりに MySQLi あるいは PDO_MySQL を使いましょう。

Change History

comment:1 Changed 6 years ago by nanasess

PDO にすると、シーケンスの扱いが変わるので、工夫が必要ですね。

Note: See TracTickets for help on using tickets.