Ticket #2537 (new 改善提案)

Opened 7 years ago

Last modified 6 years ago

郵便番号の入力チェックで使っている NUM_COUNT_CHECK が分かりにくい

Reported by: Seasoft Owned by: somebody
Priority: Milestone: バックログ
Component: その他 Version: 2.13.1
Keywords: Cc:
修正済み: no

Description (last modified by Seasoft) (diff)

単なる文字数チェックなら、MAX_LENGTH_CHECK, MIN_LENGTH_CHECK に倣った、汎用的に使えそうな関数名にしたい。

若しくは、NUM_CHECK + 文字長チェックといった複合的な機能を持たせるのも良いかもしれないが。

はたまた、郵便番号チェック専用として用意するのも合理的かも。(電話番号にも言えそう。)

Change History

comment:1 Changed 7 years ago by Seasoft

  • Description modified (diff)

comment:2 Changed 6 years ago by kim

  • Milestone changed from EC-CUBE2.13.3 to バックログ

仕様検討バックログへ

Note: See TracTickets for help on using tickets.