Ticket #2479 (closed バグ指摘: 修正済)

Opened 7 years ago

Last modified 7 years ago

COMPLIANT_VERSION の許容文字数が不足

Reported by: nanasess Owned by: dkazuto
Priority: Milestone: EC-CUBE2.13.2
Component: 管理画面 Version: 2.13.0
Keywords: Cc:
修正済み: yes

Description

プラグインの構成ファイルである、 plugin_info.php の COMPLIANT_VERSION は、プラグインをインストールする際、 最大文字数チェックがかかる。 最大文字数チェックは、 STEXT_LEN でかかるため、多くのバージョンに対応しようとすると、最大文字数エラーとなってしまう。

// 以下でエラーとなってしまう
static $COMPLIANT_VERSION = "2.12.0,2.12.1,2.12.2,2.12.3,2.12.4,2.12.5,2.12.6,2.13.0,2.13.1";

文字列を渡しているだけなので、LTEXT_LEN にしても良いと思われる。

Change History

comment:1 Changed 7 years ago by dkazuto

  • Owner changed from somebody to dkazuto
  • Status changed from new to assigned

comment:2 Changed 7 years ago by dkazuto

  • Status changed from assigned to new
  • 修正済み set

r23303 にて対応させていただきました。

comment:3 Changed 7 years ago by h_yoshimoto

ご対応ありがとうございます。
ご対応いただいたチケットのステータスはassignedにしていただくようお願いいたします。

参考
http://svn.ec-cube.net/open_trac/wiki/%E9%96%8B%E7%99%BA%E6%89%8B%E9%A0%86

comment:4 Changed 7 years ago by h_yoshimoto

  • Status changed from new to closed
  • Resolution set to 修正済

comment:5 Changed 7 years ago by h_yoshimoto

ご対応ありがとうございました。

Note: See TracTickets for help on using tickets.