Ticket #2224 (new バグ指摘)

Opened 7 years ago

Last modified 4 years ago

プラグイン機能 テンプレートに対するトランスフォームが環境によって正常に動作しない

Reported by: AMUAMU Owned by: somebody
Priority: Milestone: EC-CUBE2.13.x
Component: フロント Version: 2.12.3
Keywords: プラグイン transform トランスフォーム Cc:
修正済み: no

Description

PHPがリンクしているlibxmlのバージョンが2.7未満の場合に生じる問題

具体的な不具合
・テキストのみのテンプレート(主にメールテンプレート)の場合に、libxmlのバージョンが古いと記号類が数値参照形式になってしまう。
・長大なHTMLの場合、正常にパースできない

パース自体が失敗している場合に処理を迂回するような改修の必要性がありそうです。

詳細は下記コミュニティ内にて  http://xoops.ec-cube.net/modules/newbb/viewtopic.php?topic_id=12017&forum=10&post_id=55450#forumpost55450

※主にhetemlサーバーで生じる模様

Change History

comment:1 Changed 7 years ago by kim

  • Priority changed from to

comment:2 Changed 7 years ago by h_yoshimoto

  • Milestone changed from EC-CUBE2.13.0 to EC-CUBE 2.13.1

comment:3 Changed 7 years ago by m_uehara

  • Milestone changed from EC-CUBE 2.13.1 to EC-CUBE 2.13.2

comment:4 Changed 6 years ago by h_yoshimoto

  • Milestone changed from EC-CUBE2.13.2 to EC-CUBE2.13.3

comment:5 Changed 6 years ago by kim

  • Milestone changed from EC-CUBE2.13.3 to EC-CUBE2.13.4

ひとまず次期バージョンへと移動します。

Note: See TracTickets for help on using tickets.