source: branches/version-2_13_3/.travis.yml @ 23612

Revision 23612, 776 bytes checked in by kimoto, 7 years ago (diff)

#2610 PHP5.6対応
travis.ymlにPHP5.6を追加

Line 
1# for travis-ci
2# see also. https://travis-ci.org
3language: php
4
5php:
6  - 5.6
7  - 5.5
8  - 5.4
9  - 5.3
10
11env:
12  - DB=mysql USER=root DBNAME=myapp_test DBPASS=' ' DBUSER=root
13  - DB=pgsql USER=postgres DBNAME=myapp_test DBPASS=password DBUSER=postgres
14
15before_script:
16  - curl -s http://getcomposer.org/installer | php
17  - php composer.phar install --dev --no-interaction
18  - sh -c "if [ '$DB' = 'mysql' ]; then sh ./eccube_install.sh mysql; fi"
19  - sh -c "if [ '$DB' = 'pgsql' ]; then sh ./eccube_install.sh pgsql; fi"
20  - cp tests/require.php.jenkins tests/require.php
21  - cat ./data/config/config.php
22  - npm install -g grunt-cli
23  - npm install
24
25script:
26  - mkdir -p reports/coverage
27  - phpunit -c phpunit.xml.dist
28  - grunt
29
30after_script:
31  - php vendor/bin/coveralls -v
Note: See TracBrowser for help on using the repository browser.