source: branches/comu-ver2/data/module/Smarty/INSTALL @ 15079

Revision 15079, 1.4 KB checked in by nanasess, 14 years ago (diff)

svn:mime-type application/x-httpd-php; charset=UTF-8 設定

  • Property svn:mime-type set to application/x-httpd-php; charset=UTF-8
Line 
1REQUIREMENTS:
2
3Smarty requires PHP 4.0.6 or later.
4See the on-line documentation for complete install instructions.
5
6INSTALLATION (quick):
7
8* copy the files under the libs/ directory to a directory that is in your PHP
9  include_path, or set the SMARTY_DIR constant and put them in this directory.
10  (if you upgrade from versions before 2.5.0 be aware that up to Smarty 2.4.2
11  all necessary files where in the distribution's root directory, but are now
12  in libs/.)
13
14* for each application using Smarty, create a "templates", "configs", and a
15  "templates_c" directory, be sure to set the appropriate directory settings in
16  Smarty for them. If they are located in the same directory as your
17  application, they shouldn't need to be modified. Be sure the "templates_c"
18  directory is writable by your web server user (usually nobody). chown
19  nobody:nobody templates_c; chmod 700 templates_c You can also chmod 777 this
20  directory, but be aware of security issues for multi-user systems. If you are
21  using Smarty's built-in caching, create a "cache" directory and also chown
22  nobody:nobody.
23
24* setup your php and template files. A good working example is in the on-line
25  documentation.
26
27* TECHNICAL NOTE: If you do not have access to the php.ini file, you can change
28  non-server settings (such as your include_path) with the ini_set() command.
29  example: ini_set("include_path",".:/usr/local/lib/php");
Note: See TracBrowser for help on using the repository browser.